3D View Window

From Protocase Designer Documentation
Jump to: navigation, search

3D View Window overview

The 3D View window displays a 3D model of your enclosure that you can manipulate.
A: 3D Standard toolbar
B: 3D Viewport
Window-main-labels NEW.png

3D Standard Toolbar

3d standard toolbar NEW.png

From left to right, the buttons are as listed below. Known Limitation: As of Version Jun09,16, which introduces new 3D View tools, the Edit Face button is displayed only in the left-hand toolbar. Prior to Version Jun09,16, the Edit Face button is in the 3D Standard toolbar.:

Bent button NEW.png Bent View assembly with faces bent as in final manufacture.
Flat button NEW.png Flat View assembly with faces flattened.
New button NEW.png New Create a new enclosure (load a new template).
Open button NEW2.png Open Open an existing assembly (.PDA) file.
Save button NEW.png Save Save the current design.
Save-as button NEW.png Save As Save the current design under a new filename.
Reset View button.png Reset View Reset the view to the original default view.
View-angle button NEW.png View Angle View assembly from the front, right, top, left, back, or bottom, or in the default isometric mode. Note that if you rotate or zoom in any angle view, the view returns to isometric.
Part-tree button NEW.png Part Tree Open the Assembly Tree dialog, which details all parts and faces for the current assembly.
Help button NEW.png Question Open the help dialog, which lets you submit a question about your design and send it, with or without the design file and/or the debug log files, to Protocase Engineering & Design Services.
Rotate button NEW.png Rotate Rotate the view.
Pan button NEW.png Pan Pan the view.


3D View Preferences

If you want to use a different unit of measure or have other preferences when using Designer, you can set global parameters in the Preferences dialog box.

Creating, opening, and saving assembly files

Creating a new assembly

  1. Click the New File button in the Pick An Option To Start window, choose File > New, or click the Make New Enclosure From Template button Make new enclosure from template button 3DView.png in the 3D Standard toolbar. The New Assembly dialog opens.
    Window-newassembly-noselection NEW.png
  2. Select an assembly category on the left and then select an assembly.
    Window-newassembly-ushape NEW.png
  3. Modify the assembly parameters including size, thickness, material, and colour to meet your design requirements, conforming to any Manufacturing Constraints if they are listed at the bottom of the window. See Changing enclosure properties below for details.
    • Note: To create a custom bracket with cutouts and other elements, you use the 3D View window to create it, then you use the Face Editor to customize it and to add it to a face. See Creating and adding brackets for step-by-step instructions.
  4. Click OK to view the 3D model.
    Window-main-ushape NEW.png

Opening an existing assembly

  1. In the 3D View window, choose Open from the File menu, or click the Open button in the Standard toolbar.
  2. Select the file you want to open.

Saving an assembly

Files are saved in .PDA (Protocase Designer) format. (Note that you cannot save the enclosure design as a modified template; you can only save the enclosure design.)

  1. Choose File > Save or click the Save button in the Standard toolbar.
  2. If this is the first time the assembly is being saved, the Save dialog box opens. Select a location and enter a name for the file, then click Save.

Saving a copy of an assembly

  1. Choose Save As from the File menu, or click the Save As button in the Standard toolbar.
  2. In the Save dialog box that opens, select a location to save the file and enter a new name for the assembly, then click Save.

Changing assembly properties

At any point after you create a new assembly (enclosure, bracket, or panel) you can modify its properties such as size, thickness, material, colour, and screw type.

  1. Choose Edit > Edit Enclosure Properties. The Edit Assembly dialog is displayed.
    3D view Edit Properties dialog NEW.png
  2. Change any of the enclosure properties, being sure to conform to any Manufacturing Constraints if they are listed at the bottom of the dialog.
  3. If the template includes screws, the Screw Type is displayed with a default value. (Brackets and panels do not use screws.) To change the default screw, click the Screw Type down-arrow and choose the color (Black, Natural [Zinc], or Stainless) and type (Flathead or Panhead).
  4. To save the modifications, click OK.

Note

  • When you select a rackmount enclosure template, the parameters include the Full Height Chassis check box. Selecting this checkbox causes the screws to be countersunk, and the enclosure the same height as the front of the rackmount.

Transferring an enclosure design

  1. Open the design that you want to transfer.
  2. In the 3D View, choose File > Transfer to New Enclosure.
  3. In the Transfer Design to New Assembly dialog that opens, select the new enclosure and modify parameters as needed.
    Designer will transfer parameters for enclosures of the same category; for example, if you are transferring between two types of Extruded enclosures, nothing needs to be changed. However, if you are transferring from a U Shape to a Rackmount, you may need to change some parameters manually.
  4. Click OK.
    An untitled dialog opens, in which the face names of the original enclosure are listed on the left, and to the right of each name is a column of potential face names for the new enclosure. When the two designs use different names for a face (for example, a Rackmount has a "front panel," whereas a 1U Extruded has a "front plate," whereas a U Shape has just a "front"), select the appropriate face name for the new design. Many of these are pre-selected, but check them all and change the name or choose "Drop This Face" as necessary.
    Tip If you are unsure of a face name for an enclosure, you can check by loading the enclosure and viewing the face in the Face Editor. The face name is displayed in the Status Bar at the bottom of the Face Editor screen.
  5. Click OK when done (or Cancel to abandon the new enclosure template and return to your original design).
  6. Check each element of the new design against your original. For some transfers, the cutouts may need to be flipped or moved manually.

Viewing the model

There are several controls to allow viewing and manipulating the 3D model of your enclosure.

Rotating

The Rotate command rotates the model around its center.

  1. Click the Rotate Rotate button NEW.png button in the Standard toolbar.
  2. Drag the model to rotate it to the desired orientation.

Panning

To move the model around the plane of the viewport, do any of the following:

  • Right-click the model and drag it.
  • Press and hold down the <Alt> key, then click and drag the model.
  • Click the Pan Pan button NEW.png button in the Standard toolbar, then click and drag the model.

Zooming

To zoom the model in or out, rotate the wheel button forward or backward.
Notes

  • The model zooms in/out from the centre of the viewport, regardless of the pointer location.
  • If your pointing device does not have a wheel, open the Face Editor and use the Zoom In and Zoom Out buttons in the Standard toolbar or the Zoom commands in the View menu.

Show/Hide Parts

The Show/Hide Parts command lets you view inside the model by hiding one or more parts.

  1. Choose View > Show/Hide Parts. The Show/Hide Parts dialog box is displayed.
  2. Select or clear the appropriate check boxes to show or hide parts.

Toggle flat/bent view

The Toggle Flat and Bent commands displays the enclosure parts as they are laid out prior to the bending process during manufacturing. These commands are for reference only, and do not affect the manufacturing of the final enclosure. You can do either of the following:

  • To display the model in a flat view, click the Flat Flat button NEW.png button in the Standard toolbar. To display the model in the bent view, click the Bent Bent button 3d standard toolbar.png button. By default, the model is displayed in the bent view.
  • You can also change between the two views by choosing View > Toggle Flat.

Reset view

The Reset View command displays the model in the center of the viewport in its original orientation.

  • Click the Reset View button Reset View button NEW.png in the Standard toolbar, or choose Reset View from the View menu.

Editing a face

You use the Face Editor to add cutouts, graphics, exclusion zones, masking, and construction lines to a face.
To open the Face Editor:

  1. Rotate the model to show the face you want to edit.
  2. Click the Edit Face button. Button-editface NEW.png. The pointer will change to a crosshair.
  3. Click a face to edit. The Face Editor window opens.

Tools


The Tools section of the 3D Viewer has three tools: Move/Rotate, Dimension, Face to Front

PD Tools.PNG

Move/Rotate: Rotate your project.
Dimension: The 3D Dimensioning Tool was released in Protocase Designer 5.4.8. It provides the ability to place persisting dimensioning lines while in the 3D viewer within Protocase Designer.
To use the 3D Dimensioning Tool:

  1. In the 3D viewer, click Dimension.
  2. Select the styles of snap points you want for your dimension lines:

PD Wiki 3D Dimensioning.PNG

  • Profiles: The end points of lines or objects. Can be corners or the end points of lines in a cutout.
  • Midpoints: The center points of lines/edges (including tangents of circles since they are comprised of 4 arcs/2 semi circles)
  • Centers: the middle point inside your cutout.
  • Origins: These are based on how you place your cutout in designer. Origins provide snap points wherever your cutout started. For example, the center of a circle or first corner of a rectangle.


To Select a 3D Dimension

  1. Select your first snap point to begin placing your dimension line. Move your cursor to the next point, click to select it in order to finish placing your line.
  2. Your dimension line will be placed. You can select the line and drag it out to view it more easily.
  3. Press space bar to toggle through different viewable dimensions while the line is selected until you reach the desired dimension.

PD Wiki Example of 3D Dimensioning.PNG

  1. On the right side of your screen within the 3D viewer, you'll find a list of dimension lines. You can expand the line in this menu or by clicking on the line in the 3D viewer in order to see the delta values for the line.

You can also hide or show Dimension Lines by clicking the eye icon beside each Dimension Line.

PD Wiki Hide or Show 3D Dimension Lines.PNG

Important Note: Due to the lack of perfection when translating your CAD model into a physical design, your dimension lines may vary between Protocase Designer and your real-life part or enclosure based on our [manufacturing tolerances]. This will be much more pronounced when creating a diagonal measurement between faces. For this reason, it is strongly recommended to not dimension a diagonal line between perpendicular faces. The dimensioning tool can still provide useable vector dimensions for height, width or depth.


Face to Front:

Click the face of your design that you want to face forward. Note: You may need to zoom out in order to see all of the design.

Viewing the Part Tree

The Part Tree shows a hierarchical list of all the faces and objects in your enclosure. You can change the name and description of objects as well as open a face in the Face Editor Window directly from the Part Tree.
Window-parttree-ushape-note NEW.png

Navigate the Part Tree

  1. Click the icon to the left of a face to display the objects on that face below.
  2. Click an object name to display description, and notes on the right of the Part Tree window.

Change object name and description

  1. Click an object name on the left.
  2. Type a new name or description on the right.

Add/Delete notes

You can add notes to parts, faces, and objects for your own reference or to provide additional information to technical support such as "Please scrub this with a scouring pad". You can also use it to place features that might not be permitted in Protocase Designer but can be manufactured with certain restrictions. For example, you could create a circle using construction lines near the edge of a face on the exclusion zone (where you wouldn't normally be able to place a self-clinching standoff) and add a note "Add 6-32 x 3/8" standoff here".

  1. Click an object name on the left.
  2. Do one of the following:
    • If there are no notes, type a note in the notes field.
    • If there are existing notes, click New Note and type a note in the notes field.
  3. Click the arrows to view each note.
  4. Click Delete Note to delete the currently displayed note.

Editing a face from the Part Tree

  1. Click a face name on the left.
  2. Click Edit Face. The Face Editor window opens.
    Window-parttree-ushape-editface NEW.png

Note: The Part Tree window can also be accessed from the Face Editor.

Exporting an IGES file

You can export your PDA file into an IGES file, allowing you to import your project into other CAD software.
This IGES export feature is currently only compatible with the 2018 release of Solidworks (as well as NX).

  1. Open the existing PDA file that you saved from the Protocase Designer software
  2. Select the Export Menu, and in the drop down, click Export Assembly to IGES.
    Note: Depending on the complexity of your design, the software could take a considerable amount of time to export the file, as it must export each feature individually.
  3. Once the export is completed, you can now open your exported IGES file in various CAD software.

Note: In order to import your IGES file into SolidWorks 2018, the Enable 3D Interconnect setting must be enabled. This can be found under Tools->Options->Import->General.
Also, this is currently only intended as a means of archiving your projects. We are working on improvements to this functionality to increase the usability of the exported file.
This will be released in a future version of Designer.

View full video tutorial here: https://www.youtube.com/watch?v=Fdyi_QXU7M0

Exporting a STEP File

You can export your Protocase Designer Assembly as a STEP file, allowing you to import your project into other CAD software.

To export your file:

  1. Open your existing PDA file saved in the Protocase Designer software.
  2. Select the "Export Assembly to IGES" option under the Export Menu in the tool bar at the top of your screen.
  3. The software will process your request. The time that this step will take depends on the complexity of your design.
  4. Once the export is completed, open your other CAD software and select your design.

Note: We support AP203 and AP214 STEP Application protocols.